Strange Sound Bug/Glitch in SWBF (2004) for Steam

Started by SparkHunter23, July 18, 2021, 01:56:45 PM

Previous topic - Next topic

SparkHunter23

So I wanted to hop onto Battlefront 1 again and as soon as I started playing, I noticed a strange audio glitch that keeps on happening from time to time. It seems like the sound effect for zooming in, shooting, explosions, reloading etc. get buffered or in other words they seem to stutter. For example: I was playing as the sharpshooter and the blaster sound effect was triggered 3 times. I have tried reinstalling the game and putting every setting back to default but the issue still persists. I've seen some people addressing this on Steam Discussions and they didn't know a fix for it either so I really hope someone on this forum knows a solution. 

Thanks in Advance

Led

do you play multiplayer or singleplayer?

If single player and/or you want to use SWBFspy instead of Steam servers, then you can try our reversion patch.
Quote from: Abraham Lincoln. on November 04, 1971, 12:34:40 PM
Don't believe everything you read on the internet

wsa30h

did you enable vsync ? its a simple fix but it works. also can happen when playing the game at 4k.
mods and maps in progress:<br />--Bf1 expanded edition 3.0 version
-- bf1 tcw battles
-- bf1 seasons mod season 1
-- bf2 expanded edition tbh

SparkHunter23

Thank you guys for the help.
Yes I am just talking about singleplayer, and as it turned out, by enabling vsync the issue might be fixed. However, now the main menu theme sometimes doesn't play for me anymore :/.