Antstafer's Many Modding Problems

Started by Antstafer, August 30, 2021, 01:06:12 PM

Previous topic - Next topic

Antstafer

August 30, 2021, 01:06:12 PM Last Edit: August 31, 2021, 10:33:04 AM by Antstafer
Sorry for yet another help topic, but I seem to keep running into the most bizarre problems. Spent the whole day troubleshooting this, so time to ask for help.

In a nutshell, I'm adding water to the naboo plains map.

I followed This tutorial and another one, and I'm sure I followed everything correctly.


Now, the water seemingly Isn't the big culprit here, but it might leave a clue.

The main issue I'm having is when I add this to my modid.reg-

REQN
{
"envfx"
"naboo1"
}

This causes the main modid munger to output this error code-
"Error: (null) is not a binary UCF file!Error: munged\naboo1.envfx is not a binary UCF file!

This results in a finished munged map with a size of 921KB, which in turn loads a blank map at launch.


But if I change it to look like this-
REQN
{
"envfx"
}

Deleting the "naboo1" line causes the munger to output numerous errors (to be expected), BUT, it successfully munges a map of 13MB. Obviously crashes, but still, it makes an effort to munge the world file.


I really have no idea where to go from here.

--------
EDIT: This is now my official thread to annoy the expert modders here with my many troubleshooting problems  :)

Antstafer

For more clarification, it doesn't even attempt to make the world folder-

Led

Quote from: Abraham Lincoln. on November 04, 1971, 12:34:40 PM
Don't believe everything you read on the internet

Antstafer

Quote from: Led on August 30, 2021, 03:29:19 PMAh, I see it is marked solved.

Here is another post where there was an issue with water:

http://www.swbfgamers.com/index.php?topic=13249.msg120300#msg120300

Thanks, Led

And I really don't want to make another topic just for this, but you're pretty experienced, maybe you can help.

So like I said, I'm working on editing the Naboo: Plains map. I added a few extra trees and statue heads, and expanded the whole mapspace by around 2x.

Not only does the foliage not show up in game, but having the view distance any more than half crashes the game. I've made and played on maps much denser and much larger than what this is right now, so I doubt its due to hitting the polygon limit cause I didn't add many objects, and normally you just see objects disappearing once that's reached. Any ideas what could be causing it?

Antstafer

I also got SPTest to work, and it gave this error right before it crashed-

Message Severity: 2
.\source\EntityHover.cpp(561)
Hover fell thru' terrain, x = -336.196930, z = -204.267136


Is there a way to easily find where this is in zero editor?

Antstafer

Nope, never mind. Further tests in SPTest don't seem to give an exact error before it decides to crash.

Dark_Phantom

Are you adding anything other than stock objects?
Are you looking a certain direction when you crash?

Usually with just a bunch of objects and a large space, the game will not crash.  It usually has to do with a broken object or some other factor, like water.
The BOBclan:  A Rich History


Quote from: Unit 33 on November 29, 2014, 03:44:44 AM
'Please, tell me more about the logistics of the design of laser swords being wielded by space wizards' - Some guy on the internet.

Antstafer

Quote from: Dark_Phantom on August 30, 2021, 08:28:39 PMAre you adding anything other than stock objects?
Are you looking a certain direction when you crash?

Usually with just a bunch of objects and a large space, the game will not crash.  It usually has to do with a broken object or some other factor, like water.

Nope, only using objects that shipped with naboo plains. All the water has been removed from the level (I was doing some tests with adding a river), but there's a possibility a tile or two could have been missed, which would make sense why lower viewing distances wouldn't pick it up, since they'd be hugging the edge of the map most likely.

If I find anything useful, I'll report back.


EDIT: Nope, no missed water tiles.

Antstafer

Quote from: Dark_Phantom on August 30, 2021, 08:28:39 PMAre you adding anything other than stock objects?
Are you looking a certain direction when you crash?

Usually with just a bunch of objects and a large space, the game will not crash.  It usually has to do with a broken object or some other factor, like water.

Actually Phantom, you were right. I did a couple spawn tests for 1 minute each, and looked in 4 different directions. it only crashes when I turn to the right side of the map.

So, that gives me a clue, but I still don't know where to begin troubleshooting besides deleting objects.

Antstafer

Well, I may have found the culprit.

Did some searching around on that side of the map, and found nothing. Until I searched out beyond the terrain-



There's foliage going up some invisible wall.



Shot in the same spot looking up into the sky ^


Absolutely bizarre. I can't seem to delete or get rid of them like regular foliage. And they aren't objects. tried on all two layers.

Absolutely stumped.


EDIT: Managed to sort of trick the foliage brush. This seems to be getting rid of them.

Antstafer

Welp, that didn't make any difference it seems. Still crashing when looking to the right, or venturing out in the map too far in one direction.

Giftheck

Do you have an .FX file in your World folder, containing a Water section? That stung me for ages on Scarif before I figured that one out. What I'd do is copy one from one of the stock world folders (IE Kashyyyk Docks) and rename it to your world file. You then need to edit your .REQ and un-comment the 'envfx' section.

And are you including all the water textures in your Effects folder, and referencing them in the .REQ?
Works in Progress:
--Star Wars: Battlefront 1.25: "First Order-Resistance War Expansion"
--Main Play Mod Reboot
--Star Wars Battlefront Legacy Reboot
--Star Wars Battlefront: Elite Squadron For SWBF1

Antstafer

Quote from: Giftheck on August 31, 2021, 03:32:12 AMDo you have an .FX file in your World folder, containing a Water section? That stung me for ages on Scarif before I figured that one out. What I'd do is copy one from one of the stock world folders (IE Kashyyyk Docks) and rename it to your world file. You then need to edit your .REQ and un-comment the 'envfx' section.

And are you including all the water textures in your Effects folder, and referencing them in the .REQ?

That's some good stuff to keep in mind, but there's no water on the map anymore, nor is any of it referenced in the reqs.

Low view distance is fine, its only when its on high and I turn to the right side of the map, or go out too far does it crash

Antstafer

Just started from scratch again with a completely default shipped world. No crashing.

I used to be pretty good about making an edit and testing, but I got a little cocky this time around, and paid the price.

New map makers, ALWAYS test your maps, even after the smallest change haha. Save yourself days of troubleshooting.

Antstafer

August 31, 2021, 09:12:29 PM #14 Last Edit: August 31, 2021, 09:30:12 PM by Antstafer
Any tutorials on adding foliage? I can't find any documentation anywhere on how to add it.

EDIT: Figured out something by myself for once!

For anyone else having trouble, go into your modid.reg file and edit out the '--' next to the prop line-

REQN
    {
        "prop"
    --    "modid"
    }


Foliage is handled by the modid.prp file in your world folder. You can edit it with notepad like most of the other files if needed.