Author Topic: Sound Problem  (Read 293 times)

MoonDeity

  • Member
  • **
  • Posts: 22
    • View Profile
    • Awards
Sound Problem
« on: April 03, 2020, 07:41:16 PM »
Im currently using the steam version and I made a new Common.bnk file to change the sound effects. All the new sound effects are the same type of .wav file as the old ones. The sound effects are changed and they work but my problem is on some planets like Felucia, Hoth and Geonosis there is absoloutly no sound effects and its just the sound effects. I can hear the background ambiance and everything but there are no guns, vehicles or movements. Does this game have a restriction or something? If so is there a way I can fix it? Please help me, I was almost making this game renewed.

Also I dont know if its my computer or not but the planets that are working have I guess what you would call pretty bad stuttering. Sounds skip over eachother and dont play out smoothly alot.
« Last Edit: April 03, 2020, 08:48:21 PM by clsallenbach »
"Im just a simple man trying to make his way in the universe"

NB20026

  • Frequent Poster
  • ****
  • Posts: 221
    • View Profile
    • Awards
Re: Sound Problem
« Reply #1 on: April 03, 2020, 09:46:36 PM »
How big is current common.bnk file ? When I was making sound files size was a problem

Dark_Phantom

  • The Official Ghost
  • Administrator
  • This Man Has No Life
  • *****
  • Posts: 1349
  • Awards SWBFspy SWBF1-Player of the Month To recognize Modders that make a most excellent contribution within the Month A member of the winning team of ICW6 Administered events in ICW5 A member of the winning team of ICW5 Special Award for those that play the original SWBF ICW4 Participant Recognizes someone who most generously donated funds to the site or the site ICW3 Participant
    • View Profile
    • The BOBclan
    • Awards
  • PSN: phantom567459
  • Steam ID:
  • Origin ID: phantom567459
Re: Sound Problem
« Reply #2 on: April 04, 2020, 01:10:53 PM »
The 3 of those planets are probably memory hogs, and they probably have a lot of ambient noise built into the sound.lvl file.
Did you see if they work with an unedited version of the common.bnk builder?  If they do, somewhere along the line you're going to have to cut your noises back.
The BOBclan:  A Rich History


'Please, tell me more about the logistics of the design of laser swords being wielded by space wizards' - Some guy on the internet.

MoonDeity

  • Member
  • **
  • Posts: 22
    • View Profile
    • Awards
Re: Sound Problem
« Reply #3 on: April 16, 2020, 06:33:10 PM »
The problem is polis massa for galactic civil war. All my sounds are properly sampled and everything and I created a fresh common.bnk with no changes and it still doesnt work. Something is missing from my common.bnk that was in the original common.bnk i think.

IDK i just spent a whole day trying to figure it. The ffpeg batch converter crashes when i tried to change the pol.lvl sounds because I was going to try and put the pol.lvl sounds in the common.bnk folder to see if I could munge it and it would be complete than.

Im probably not making any sense but if anyone ever has time to help me I would be very grateful. People really appreciate this addon/mod and I wont be the only one hoping that its possible to fix

Edit:

I will be very grateful to anyone that can help me and give credit on my mod.

This is about a sound mod and creating a new common.bnk file.

My problem is im using a tool to munge the common sound files into the common.bnk file but when I replace the original common.bnk file there is no sound for GCW on Polis Massa. All my sounds are sampled properly and all the right sizes, Ive already gotten passed the memory problem awhile back. Even if its a brand new common.bnk file I munge with no sound changes or anything, it still doesnt want to have sound on Polis Massa. I beleive the common.bnk I am making is missing something the original common.bnk has.

First of all is there a way to tell whats missing? Secondly is there a sound tutorial somewhere for this? Ive been able to extract sounds from the files but I tried using the ffmpeg batch AV converter and it crashed when I tried to use it over and over. I have a problem turning the raw data wav files into regular wav files so they are playable and usable.
Im thinking if I can convert the sound files out of pol.lvl properly I might be a step closer to finding whats missing.

If anyone even has link to the sound mod tutorials or a good converting sound tutorial or anything in these categories that would be awesome. I just spent all day googling and trying to find a way to solve this dilemma. Alot of people really like this mod and you would be doing them a favor as well.

I extracted the sounds from the original common.bnk and its different...Oi I need a protocol droid

Edit by Anyder: Please refrain from posting 10 times the same question. If nobody replies as fast as you expect it means we didn't have the time. Thanks for your comprehension.
« Last Edit: April 16, 2020, 11:16:43 PM by clsallenbach »
"Im just a simple man trying to make his way in the universe"

 

SimplePortal 2.3.7 © 2008-2020, SimplePortal