Author Topic: Object not appearing on the map after I munge, what am I doing wrong?  (Read 238 times)

mat1313

  • Recruit
  • *
  • Posts: 2
    • View Profile
    • Awards
Hi everyone!

I'm new to modding battlefront (and to the forum too) and after messing around for a long time today I successfully managed to add my first custom object to my map and munge it. The problem is the object doesn't show up when I play the game. The object is a simple cube, it has a 1024x1024 tge texture and it looks perfect in the SWBFViewer and in Zeroeditor too. After I munged the map and tried it I couldn't find it anywhere. :confused:

What am I doing wrong?

Led

  • Administrator
  • The Chosen One
  • *****
  • Posts: 7260
  • The 82nd Element
  • Awards For those who play any version of the 2016+ EA games Special Award for those that play the original SWBF
    • View Profile
    • Awards
  • Steam ID:
  • Tunngle ID: _PLA-Led
  • Origin ID: plaled
Re: Object not appearing on the map after I munge, what am I doing wrong?
« Reply #1 on: September 03, 2019, 05:12:21 PM »
Perhaps you also need an ODF (object definition file), a req file, and collision.

A good way to check what you might need is to look at a stock map, find an object, and then look through the files for the other required information.

For example, here is a fountain in cloud city:
bes2_bldg_courtyard_fountain.odf

Code: [Select]
[GameObjectClass]       

ClassLabel      =   "prop"
GeometryName    =   "bes2_bldg_courtyard_fountain.msh"


[Properties]       

GeometryName    =   "bes2_bldg_courtyard_fountain"

SoundProperty = "minifall"
FoleyFXGroup    = "metal_foley"


also, welcome to the site  :cheers:
Don't believe everything you read on the internet

mat1313

  • Recruit
  • *
  • Posts: 2
    • View Profile
    • Awards
Re: Object not appearing on the map after I munge, what am I doing wrong?
« Reply #2 on: September 04, 2019, 09:13:48 AM »
Thank you for your reply! :)

I already had the odf file, but I realised since what was the problem. I forgot to install the 1.3 patch.  :slap:
I had it installed on the steam version, but I've switched to the GOG version not so long ago and I forgot to install it there too. Now my cube appears on the map as intended.

EDIT: The weird thing for me was that Battlefront 2 opened the munged map without crashing while missing the 1.3 patch, the terrain was good, just I couldn't find my object.

Thanks for the help again even though I was the big dummy.
« Last Edit: September 04, 2019, 09:17:01 AM by mat1313 »